Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Yet another stupid I.T. question from Hornet

Discussion in 'The Pub' at netrider.net.au started by hornet, Sep 15, 2013.

  1. So, I'm trying to help out a lady who has broken the USB connector off her portable hard drive. I've exhumed the drive from its casing and removed the USB/SATA interface, and determined that it's a stock standard SATA drive (1Tb capacity).
    I have at least TWO hard drive docks, which SHOULD allow me to plug the drive in and at least read the contents on my computer (and copy them off so she doesn't lose them.) NEITHER of them work.
    I plug them in (Windows 7 Professional, i3 computer on a plain vanilla Gigabyte motherboard, USB 2 and USB 3 ports available), Windows tells me they are there, shows me a USBtoSATA bridge, but will NOT bring up the drive as an icon in "Computer". I tried three other drives (two SATA and one old IDE) on this dock and my other one, same result :? :?. What am I doing wrong; if I plug in a USB stick, it comes up straight away. Why doesn't this work when I'm sure it used to (which is why I offered to help in the first place)???


     
     Top
  2. Does the dock require, or have the capacity to use, an external power source? I've had drives that simply will not read without an external power supply in addition to the USB connection to the dock.

    edit: if it's a 3.5" drive it will definitely need the external supply.
     
     Top
  3. Yes, the drive dock is externally powered, both of them are, in fact, and they deliver power to both 3.5" drives and 2.5" drives though a power port inside. Thanks :).
     
     Top
  4. Reinstall drivers, perhaps? Trying a Linux livecd is another option which might deal with the immediate problem (getting data from that disk).
     
     Top
  5. The drive wasn't formatted differently to yours was it ie: Mac or Fat32
     
     Top
  6. No, I'm sure it was attached to a PC to begin with, but it's not just that drive; as I said I've tried three others on two different docks. I'm sure it's a Win7 problem (or my computer) but I'm blowed if I know where to start looking).
     
     Top
  7. What kind of system does the owner use? If it's a Mac the drive may have been formatted to a Apple files system instead of NTFS. Others I've seen have the drive formatted to a variation of FAT32 that allows much bigger drives and files but needs an interface device to communicate with Windows. Those can often be ready natively by a Linux liveCD.

    edit: too slow
     
     Top
  8. Have you gone into "storage" (manage computer, etc) first? The drive may need a leter assigned before it pops up in my computer.
     
     Top
  9. Mmm good thought, I'll try that!
     
     Top
  10. All good suggestions above Hornet. I would add if it came from a Win8 system that uses the newer ReFS file system rather than NTFS.
     
     Top
  11. I don't think this lady is THAT advanced :LOL:.
     
     Top
  12. Connect the hard drive directly to one of the motherboard's SATA ports.

    What brand and model is it?
     
     Top
    • Like Like x 1
  13. SATA!! You kids and your fancy serial connectors, back in my day we only had ISA and parallel IDE to content with.

    Also, can anyone explain these new fangled mouses that you all seem to use today.
     
     Top
  14. Don't look at me! I don' t use no steeeenking mouse!

    [​IMG]
     
     Top
  15. Sometimes HDDs in usb cases are flashed with different controller firmware that will only respond to the USB - SATA bridge in the original casing. This is done so that the drives (which are sometimes sold cheaper in a case than buying a drive not in a a case) are not used as general purpose drives.

    I've had that happen with 3.5" SATA drives, so I guess that can happen to 2.5" drives too.

    How to fix it? I don't know. A usb connector is only 4 pins, perhaps you can get one and solder it onto the controller in the original case.
     
     Top
    • Informative Informative x 1

  16. That makes sense. I've handed the problem back to the owner, and if she wants to pursue the issue through warranty with Buffalo, then she can. I did suggest that even though the drive was the backup for her daughter's files, they should also be backed up somewhere else as well.
     
     Top
  17. ISA and IDE? Sheer luxury. In my day we had MFM with an RLL controller if you were lucky and you needed to use assembler to kick off the low level formatter!
     
     Top
  18. And no disk drives. Just audio tapes and each time the fridge kicked in the load would fail and have to start again. Bytes not Gig, Christ I thought I was lucky with 8K.
     
     Top
  19. #19 Dark Angel, Sep 17, 2013
    Last edited: Sep 17, 2013
    Assembler? Formatter? LOOGZOORY!!

    I my day we had to walk five miles through t' snow to t' school house and remember t' number of beads in t' row in t' head AND slide t' beads on t' abacus manually with t' hand!!

    Ok, really I used an ordinary audio tape deck and cassettes to save my code at home, 5.25" floppies at school, fancy double sided ones when I was feeling a tad rich, and 8" floppies for the payroll at the place I did my trade.
     
     Top
  20. Well in MY day I had to walk ten miles to school through the snow, carrying a horse.....
    While we're remembering, twin five and a quarter floppies and no hard disc on my first machine. But it DID have a fancy-schmancy CGA video card.......
     
     Top