Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Water leak problem... any suggestions?

Discussion in 'Technical and Troubleshooting Torque' started by capri727, Jun 6, 2006.

  1. Hi there,
    My husband will probably freak if he finds out I've written this, but here goes anyway:
    My ZZR600 was leaking a little water from the left hand side where the water pipes go into the radiator. Hubby replaced the o-rings thinking it would fix it and it is ok on that side now, but the right hand side is heaps worse. He has used vaseline on the o-rings (he didn't have any rubber grease at the time), and after several frustrating attempts to get it to stop leaking he has used silastic to seal the joints as well - and plenty of it! However, there is still a steady leak from the joint.
    Has anyone else had this kind of problem? If no-one has any other suggestions I'll go ahead and order a new pipe and see if that fixes it.
    (sorry if i've not used all the right terms... :oops: )

  2. pull the pipe off and check for a bent radiator pipe where it meets the hose

    are the hoses old and hard?

    the system is under significant pressure - you can't spray silastic around the outside of the joint and have it seal, nor can you use it to fill in big holes between the pipe and hose of the hose is not a snug fit.

    Are the hose clamps kinked or binding?