Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

VTR250 Starting issues & brake pad problem

Discussion in 'Technical and Troubleshooting Torque' started by YellowRider, Dec 6, 2013.

  1. Hey all,

    Wondering if anyone else is having the same issues.

    Problem 1: Seems my bike is inconsistant with starting. Turn the key, flick the killswitch and hit the ignition but it wont start. It's hit and miss with starting. I'll have to fiddle around with the switchblock to get the water temp light on so I can start the bike.

    Problem 2: Changed my brake pads but the rear break pads wont let me mount the caliper. There's clearance issues with the new pads pushing the disc few mm towards the mount.

    Any help is much appreciated!
  2. Problem 1: you need to work through the electrical (I'm assuming the starter isn't even turning). I would start with the main harness connector to the front of the bike,

    Problem 2: did you undo the master cylinder cap and push caliper the piston/s back?
  3. problem 1. pull apart your starter switch on your bar... hit the guts with a bunch of WD40 and make sure the contacts are still good on the starter and the kill switches.

    they leak and seize up after a bit, ours was getting stuck partially in and it does some funny things.

    problem 2. make sure you push the pistons back in, sounds like one side's a bit out still like @ibast said. once its over the disc they'll centre themselves ok.