Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Trouble reattaching muffler to head pipe

Discussion in 'Technical and Troubleshooting Torque' started by Kernel, Aug 3, 2011.

  1. Hi guys,
    I recently(ish) took the head pipe off my bike to get rid of the ugly paint and baked on dirt. I also took the muffler off.

    Just a little background, there is a clamp which I thought I had to take the bolt all the way out of and not just loosen, and did not realize that was tack welded onto the head pipe. So the clamp is pretty mangled up from me getting the headpipe off... but the bolt still goes back into the clamp (with considerable effort) and the clamp still tightens around (some parts of) the header pipe.

    Well I've gotten around to putting the exhaust system back on, but I've run into a bit of trouble. The muffler mid pipe does not want to go back into the header pipe. I've tried putting a bit of grease on both the mid pipe and on the composite seal sleeve inside of the header pipe, but it still does not want to go back in.

    I've tried doing it in reverse, but the clamp does not want to clear the shock reservoir when the muffler is in place.
    Any suggestions?
  2. Are the pipes burred from your efforts and catching on burrs? If so a bit of judicious sanding/filing.

    If the pipes are good, try heating the outside pipe. Even wrapping in rag and pouring boiling water on may help. If you can cool the inside pipe as well, it may assist.
  3. pictures would help as not sure of this bike...