Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Strange noise on zx6r

Discussion in 'Technical and Troubleshooting Torque' started by Jez79, Jul 31, 2008.

  1. Hi all, I ride a 99 zx6r and have been hearing a strange noise lately. At idle, the engine sounds a bit rough but under acceleration sounds fine.

    HOWEVER, when I accelerate hard and back off to change gear for example, the engine makes a bit of a splutter noise kind of like when you blow a raspberry??

    I recently had a major service done (24,000 km) and noticed valve clearances were not checked nor were carbies balanced. Maybe they weren't required??

    Any advice appreciated.


  2. How is it a major service without those being done?
  3. You bike considers you a woose for baking off.

    Could be any number of things. My first thought is an air leak in the exhaust system. Check around the headers
  4. Rough how? A mechanical noise or like it isn't idling properly? Because:

    Just sounds like overrun out of the pipe, i.e unburnt fuel being shot out the pipe. Could be out of tune. Take it back, tell them to do the service properly. 24k km is a major and at the very least the valve's should have been checked, let alone balancing the carbs.
  5. Header leak maybe AND YES take it back for a proper major service..