Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Speedo cable issues

Discussion in 'Maintenance and Servicing' started by LCGTR1970, Mar 25, 2014.

  1. Hi guys
    i have an issue thats doing my head in...
    The speedo cable on my bike has snapped (97 ducati monster).
    I bought a replacement and have tried removing the broken one to fix it.
    I have managed to successfully remove the cable from the rear of the gauge cluster, and have removed the sheath from the mechanism at the wheel...but... I cant remove the cable from the mechanism housing.
    I have tried pulling on it, but it seems to be anchored in there somewhere.
    I have also tried unscrewing the threaded fitting (which the outer sheath screws up to), but it seems to freely spin and not undo at all.
    Ive tried searching online, swearing loudly and throwing things around...but cant get no satisfaction.
    Any assistance here will be massively appreciated.

  2. #2 xryda, Mar 25, 2014
    Last edited: Mar 25, 2014
    could it just be corosion inside.aybe a bit of inox or wd40 might help. prob best to download a service manual
    ok just reread your post, i was thinking the cluster end sorry
  3. thanks for the reply,
    has anyone else got any ideas? im still stuck!
  4. is there a little grub screw locking it up ?
  5. Is there any sign of a lock mechanism on the new cable?

    I'd expect that it has just seized / rusted into position. The cable end should sit in a sleeve nearly 10mm. If it's gotten damp and rusted into position you'll be trying to break quite a bond.
    Spray heaps of RP7 or WD40 and try to wiggle the cable to break the bond. Then rip it out.
  6. Thanks for the advice guys. Turns out it was seized in there. I had to spray a tonne of wd40 and grabbed the cable with pliers and had to tap the pliers with a hammer to break the rusted grip it had...