Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Rough riding

Discussion in 'Technical and Troubleshooting Torque' started by Dupster, Jan 12, 2009.

  1. Hey I thought I might ask here,

    I have a "99" R6 and when I'm riding it especially in the high revs it doesnt ride smooth, it seems to constantly lurch back and forward (Like instead of "mmmmm", its "mm....mm....mm....mm" but when I get on the gas, it accelerates like a rocket still.

    Its gradually got worse in the 6 months I've had it and really makes the ride uncomfortable and at low speed in the wet I feel unsafe.

    Anyone got any ideas?
  2. Is it efi or carby?
    Seems like a surging problem.
    Take it to a mechanic if you are not mechanically inclined.
    Also introduce yourself here

    You may get more replies if you make your presence felt.
  3. Its Carby, I had it in for a service a month ago I shoulda got them to look at it then :/.
  4. Take it to the mechanic it needs a carby tune at the least, could be electrical worth getting it checked by someone with the right tools not worth doing yourself unless you want to have a garage full of special tools ..
  5. What condition is the chain in?
  6. the chain is rdy for replacing, I had a good look at it last night its bad!
  7. OK. Replace that and let us know if the problem persists. I'm gusessing that that was the issue.
  8. I've just Booked it in with Lane Cove Sydney City motorcycles for Wednesday:

    *New chain
    *New Pilot for the back (Started going flat 3 days ago and I can see a nail embedded, ffs!
    *Fix the annoying problem

    :idea: See how it goes and I'll post the diagnosis :idea: