Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Rear brake light wont work (fixed, too easy)

Discussion in 'Technical and Troubleshooting Torque' started by tim650, Jun 9, 2008.

  1. Hi guys i just noticed today that my brake light doesn't turn on when either the brakes are applied.

    My first thought was the fuse so i checked it, perfect, i even changed with other fuses with the same AMP rating and that didnt do anything.

    Then i checked the globe, also perfect, its just the one globe that dimmer's when bike is on/ignition, then brightens up when the brakes are applied.

    Now that i look at it, it seems to be stuck on the brightness (when brake is on) all the time, so it looks like im on the brake 24/7.

    Any ideas on what could be wrong?
    Wire's from front/back brake are stuck inside somewhere... I dont know.

    I cant also take it to the dealer cause bought privately, bikes still new..

    Thanks peeps :)
  2. Ahh i see what you mean, i looked at your thread, seems simple enough, il have to get to doing that next week when i have time too.

    Thanks for that
  3. Don't leave it too long; you don't want some numpty piling into the back of you because he doesn't know you're braking.

    Alternatively, since you're in Wollongong, you could bring it round and I'll do it for you :).
  4. Yeh I wasnt going to ride it til i fix it..

    Il take you up on your offer but :) PM sent