Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

R125 Issues

Discussion in 'Technical and Troubleshooting Torque' started by Ezup, Oct 19, 2011.

  1. Year: 2009
    Make: Yamaha
    Model: R125

    R125, 2 months old, 2400kms, stalled for the very first time today and well, its ****ed.

    The bike starts in neutral, but when put into 1st, it stalls, with the clutch lever fully in.

    I have tried adjusting the clutch cable, no change.

    The clutch cable is working however the clutch disengaging/engaging has seem to have gone on holidays.

    Resulted in a long walk home.

    One pissed of yamaha customer with no money to fix it.
  2. I would guess that your sidestand switch was loose, but you said you can feel the clutch not disengaging? Is it pulling hard, or just a little bit?

    And you shouldn't need money, isn't it under warranty?
  3. Sidestand switch is fine, i managed to get it to not stall in 1st once and the clutch wont disengage to allow for changing, so effectively it doesn't work. It pulls the same as it did before it stalled.
  4. send it back to the shop and get them to fix it at no charge.
  5. yeh should be covered under warranty, send it back to the dealer.

    does sound like the sidestand kill switch is not disengaging though..
  6. i agree, it's the side stand switch. they cause more harm than good.