Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Ninja 300 self check weird

Discussion in 'Technical and Troubleshooting Torque' started by HeavyNinja, Apr 13, 2016.

  1. I have just noticed an issue with my ninja that was not there the other day. When you turn the key to on and it does the prime and self check, it sounds like a smooth high pitched noise. Tonight it just has a quick grinding sound, bike still turned over but the initial prime of the fuel pump I assume was not the nice smooth sound, more of a quick grinding sound. Reckon I might have picked up some shit in the tank? Obviously is a concern this close to needing it for my test.

  2. All good I figured it out, in gear the fuel pump doesn't prime, so all I was hearing is the ecu I guess, once I put it in N the fuel pump primed so got proper sound lol.
  3. I am glad we cleared that up for you. Don't bother to thank us. It's what we do.
    • Funny Funny x 2
    • Like Like x 1
  4. sounds like this?
    pump may not prime with kill switch off either

    "That video shows the sound of the fuel pump not priming because it is not ready to start. This sound happens with the run switch off or with the kickstand down while in gear."
  5. Was kind of like that, but yes I parked it in gear, so it makes sense it didn't prime the pump as it has the auto cutoff if stand down in gear.