Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

new clutch still slipping

Discussion in 'Technical and Troubleshooting Torque' started by davey_charlie, Oct 18, 2012.

  1. I recently installed a complete new clutch kit in my cbr 929 after what i thought was the old clutch slipping.
    with the old clutch in high rpm it was like flicking the clutch when going wide open throttle.
    So the new clutch i installed per the manual (new plates, disks and springs) and it is still slipping.

    the clutch cable i have is a little longer than standard as i had it with bar risers for a little while as the standard cable didn't reach far enough, it now has the standard clipons back on, but ive lost the standard cable so can really try the standard cable to see if it makes a difference.

    ive only done 400km since the clutch went in.
  2. Clutch cable letting it release all the way? Or is it a hydraulic clutch?

    Is it a wet clutch? If so, whats the oil? Is it the right one for your bike?
    I had that issue with my old zzr - the clutch wasnt actually that bad but i replaced it anyway - hell id taken it apart i might as well do it while there, right? Turns out my clutch didnt like fully synthetic oil (wet clutch, obviously). Switched back to semi-synthetic and problem solved.

    Anything more than that, beyond my experiences pal, but im sure others know more :D.
  3. Type of oil ? And loosen cable to have freeplay
  4. I second on oil and free play in the cable.
  5. All sorted goes like a champ now, pulled the clutch apart and put it back together, I think I had abit too much oil in the motor making it slip