Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Indicator problems on zzr

Discussion in 'Bling and Appearance' started by conspiracytheorist, Jan 25, 2007.

  1. Hey just noticed today that my left indicator doesn't blink when its turned on. The light just stays on without blinking. Right works fine.

    I tried kicking the bike but that didn't fix it - thats as far as my mechanical skills go so I'm kind of stuck. Any ideas? :?

  2. have u tried " flashing it" maybe its shy???

    could be flasher unit is gone. or maybe check that both are on.. maybe a blown globe?

    tho a blown globe is usually indicaterd by rapid blinking of dash indicator. ( in cars atleast)
  3. :shock: :shock: :shock:
  4. And on my CBR250.

    I don't know, sorry!
  5. Try either reaching behind the fairing and checking the plug is in correctly (it hangs a few inches behind/below the indicator lens) or unscrew the fairing and check.
  6. My guess is you need a new flasher can. :)
  7. Oh, also! - the back indicator doesn't work at all. So would the back one being blown cause this problem? :)
  8. It'll probably be the flasher can.
    $3.99 @ K-mart
  9. Is there a flasher can on both sides? I checked the left rear bulb and its fine. When I indicate left I only hear one click, but when indicating right I can hear it clicking as it should be.
  10. Fiddled around a bit more, eventually found a cable link that had come apart. All good now :D

  11. Don't let that stop you from getting a big stick and giving it a good old fashion thrashing :tantrum:
  12. It did on a 1988 GSXR750 I had. Blown rear globe (or disconnected) = steady front indicator on that side.

    Replace rear globe, if it still does it, check wiring, if it still does, replace the indicator flasher unit (there should only be one, it'll be a metal round thingamajigga :) )