Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Idle issue TL1000R

Discussion in 'Technical and Troubleshooting Torque' started by cheky, Jun 2, 2009.

  1. Hi Guys,
    Im really starting to hate this damn TLR. Meant to be a showbike but im starting to think its more of a shitbike instead.

    About 4 months ago had the fuel filter replaced and also had the injector recondittioned. Problem i have is that i start the bike in the morning. idling fine then all of a sudden the idle drops like its running on one cylinder and then goes back to normal then does the same thing.

    Yesterday it did it alot worse id go to take off and the bike would splutter and almost died. Stalled a few times untill i took it for a good 2 minute thrash... I mean redline every gear. then came to a set of lights and it was running fine. Started it later on in the day and it was still fine.

    Im leaning towards maybe fuel pressure reg or pump??? only problem is that when i go to accelerate it has got the power so that eliminates my theory of reg or pump. I think im wrong and wouldnt have a clue.

    Bike is booked in with the mechanices next week but in the event someone knows what it might be i could at least do the easy parts before it gets costly.
    So far i have had different opinions where people say its the fuel pressure reg, faulty spark plug, ecu...

    Any suggestions would be appreciated.
  2. First thing I'd do is replace the spark plugs, they're cheap. The thrashing may have cleaned them up. (You're not running too cold a plug are you?)

    Were you having any problems before the injectors were cleaned?

    You can give the bike to me if you get too sick of it :wink:

    edited for spellnig
  3. Hey MV thanks for that. I have been running iridium plugs in it. It didnt do it before i cleaned the injectors and did the fuel filter. Could have any crap got on to them? i have NGK plugs, oil and filter at home all ready to put in but just havent had a chance.

    Might try that this weekend.

  4. Honestly I don't know nuffin about iridium plugs, but I have heard you can kill them pretty easily...

    Did you take the injector off to clean them or just run some injector cleaner through?

    Good luck, let us know how you go.
  5. I brought the bike to the shop. they pulled out the injectors and sent them away to be reconditioned. I have the full report at home from when they did that.

    I was also told iridium plugs can stuff up.

    I think your on to something
  6. If you haven't already done so i'd suggest asking the question over at TLzone or TLplanet. Really helpful people on both sites.

    Good luck with it.