Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.


Discussion in 'Riding Gear and Bike Accessories/Parts' started by ibast, Jan 18, 2007.

  1. Anyone used these ignition modules?

    Any good?
  2. An old thread, but did you end up getting one - how is it? I want to get one when I can. People on the SR500 Forum speak well of them.

  3. I forget why I asked the question now, as I didn't end up getting one. I may have thought mine was on the blink.
  4. Yeh, it's a gamble working out what to replace on old bikes - currently the bank account says yes to either a new coil, or hyperpak CDI...but choose wisely for you choose once! (Bike produced no spark for two days before I went away. Come back to it last night...and it starts first kick, and repeatedly does so providing it's cool! Though it did surge on open throttle and idle quite badly at one point later in the ride - something's on the way out. Am currently learning how to use a multimeter... :) From what I hear about the Hyperpak, at least you can't lose : it's a noticeable improvement on the stock CDI.

  5. Plug and lead?
  6. The coil seemed strange in regard to removing these. I emailed the previous owner last week - his reply:
    "Starting was always a problem for me,(the lead to the plug cap is a sealed unit) [...] I coundnt find a second hand coil, a new one was about 90 bucks, so an auto electrian worked his magic and fixed a lead and plug cap into the old coil..worked fine after that...I guess, but Im no expert you need a new coil[sic]."

    I'm yet to test things with the ohmeter - still getting my head around it, and now that the bike goes I'll probably double-check my readings with an auto-electrician before buying any parts.