Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

headlight dim, highbeam switch not working??

Discussion in 'Technical and Troubleshooting Torque' started by ben1, Apr 29, 2011.

  1. Hi all,

    i noticed after i got my bike serviced about 2 weeks ago that the low / high beam wasnt working, its just stays on low beam when i flick it to high beam... but when i use the finger button for the high beam it is fine...
    i have also noticed that my low beam is very very weak, when i was riding home tonight in the dark i couldnt even see 2 feet in front of me.

    does anyone have any ideas what it might be? could the mechanic forgot to wire it back properly??

    oo, i should also mention that it is taking longer to kick over now also.. i used to be able to just push the buttion for a second but now i need to hold it longer for it to kick over... this also only started once i got it back from the mechanic.

    by the way i own a hyo gt250r 10model.

  2. Get the battery charged up and then see if any of these problems have disappeared.
    If they have you may need to look at your charging system.
  3. I would also check the contacts in your light switch at the handle bar. It's been very wet and moisture gets in and they oxidize. Your flasher works independently from the light switch itself. And if that works fine then contacts at the light bulb and battery would seem ok.