Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Ducati monster 620 won't start

Discussion in 'Technical and Troubleshooting Torque' at netrider.net.au started by dockar, Oct 1, 2011.

  1. #1 dockar, Oct 1, 2011
    Last edited by a moderator: Jul 13, 2015
    OK so first off i've been a longtime lurker here since before I even got my licence. Been riding for over 2 years now and this Ducati Monster is my 2nd bike.
    Here is a video to help me explain the problem.

    [URL="
    ]
    [/URL]

    So this has been happening for about 9 months now, and it will sometimes start after a few go's, or i just give up and push it down a hill. I've taken it to 2 different mechanics 3 different times and they have both said they fixed the problem each time.... 3 weeks later it is happening again. Just had its 20k service.



    Sparkplugs/battery is fine, but i think maybe a loose connection? But all the issues ive researched on the internet cant really explain why i can push it down a hill and have it start 100% of the time this way. There is compression in the engine, but another thing I have noted is the airfilter seems to have abit of fuel on it(dont know if this is normal). Any hints on anything that may be the problem? Ive ran out of ideas and the last thing I can do it maybe take it to Fraisers(who will most likely ruin my wallet).... or sell it and buy a hyosung 650 till I have my fulls.. :|

    oh and as you can tell i'm not much of a mechanic, but I have quiet a few tools and can follow guides from the net/book i bought
     
     Top