Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

cobra pipes on 07 c50

Discussion in 'Cruisers' at netrider.net.au started by xyzbigred, May 24, 2008.

  1. need help had my cobra pipes and processor fitted thursday but now have noticed that when downshifting there is very little compression braking if that makes sense with stock pipes there was certain corners where just shifting down 1 peg was enough to wipe off a little speed to take the corner where now those same corners i need to grab a little brake to get around as no compression is this normal and also inside of exhaust tipps very dirty is this because to rich should i take back to installer and what should i tell him this my first bike ever so a bit unsure whats right and whats not.pipes look great very loud though thanks jamie


     
     Top
  2. Did the processor come pre set or does it need adjusting, like on a dyno or similar. I think some have to be tuned to the engine. I don't know a lot about this but just what I have read.

    Hope it helps.
     
     Top
  3. yeah was suposedly preset but installer was adjusting it when i arrived to pick up bike so i dont know im gunna see how milage is but i think with the black exhaust it is running rich and its starting to pop when decelerating ive read this is the cause of that to thanks
     
     Top
  4.  Top