Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Clutch and Cable Questions: 89 Spada

Discussion in 'Technical and Troubleshooting Torque' started by Mr.J, Feb 13, 2011.

  1. Hi, I have a couple of questions regarding the clutch and cable on my 89 Spada.

    1. I have been spending a bit of time detailing the bike after buying it a month ago and noticed it doesn't move as freely when it's in gear with the clutch lever in as it does when it's in neutral. ie seems to have a bit more resistance. Is this normal for motorbikes? Or would I be correct in thinking that maybe the clutch isn't disengaging fully?

    2. The second thing is that on closer inspection of the clutch cable, I have noticed that a few strands on the lever end have snapped. Would this maybe be the cause of the above.

    So I'm going to have to replace the clutch cable 8-[ and have done a google search but so far no success on finding a replacement. So if anyone has any info please let me know.

    My last question is in relation to number 1: If this is not normal, would I be doing damage to the bike if I continue to ride it (at this point I'm only riding it once or twice a week)?

    Thanks for your time,


    PS.:beer: Cheers to an awesome forum - as a total bike noob, I have learnt alot from here already!!