Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Choke problem please help!

Discussion in 'Technical and Troubleshooting Torque' started by Lukaz, Mar 16, 2012.

  1. Hey all, long time lurker first time poster.

    I just recently bought a Ducati 400ss, my first road bike.
    The bike its self runs beautifully once im rolling, but its almost impossible to cold start. The first start of the day is ridiculously hard, but as soon as I start rolling down the road its fine, and i can turn it off and on anytime after that and it doesn't skip a beat.

    The Choke seems to be the problem to me. I can get the bike to fire if the choke is on full, but then it seems to want to rev at around 4000rpm, so i roll the choke back slightly and it just stalls everytime, its extremely temperamental. After yesterday, it doesn't seem to even want to go to 4000rpm anymore when on full. I basically need to hold the revs up my self to warm the bike up and then roll out of the drive way in 1st gear with the clutch keeping the revs up so as to not let it stall. But like I said, as soon as I start actually riding the problem magically disappears, this only happens the first time I start the bike for that day, regardless of weather, Hot or Cold it doesn't seem to care.

    Please help guys! If this is an issue I can fix myself then I'l be a happy kid, I live with 2 mechanics so Im hoping we can nut it out ourselves, but I still want advice from the bike guru's first.

    Thanks all!