Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Calling all linux gurus

Discussion in 'The Pub' started by Bluesuede, Oct 15, 2009.

  1. Hoping someone can help!

    I'm wanting to load up an old laptop with ubuntu. No biggie. That bit is easy - the issue is getting the %$#$% wireless to work. Getting the PCMCIA card to actually function under linux reminds me of trying to get X windows working for different graphics cards in the linux of 10 years ago - an enormous pain in the butt.

    The PCMCIA card is a Netgear WG511v2 with the Marvel chipset. It doesn't have any driver support in ubuntu and needs enormous amounts of fiddling to set up. After hours on google, ages trying to extract Netgear inf files from their annoying smart installer packages, and then finally finding a different set of drivers that APPEAR to work as the card actually now lights up, sees broadcast SSIDs...and yet it won't authenticate. I think I've given up with it. :tantrum:

    Does anyone know of a PCMCIA wireless card that works well under ubuntu? The laptop runs like a dog under XP and as it is the laptop I'd set aside for the kids to play with I wanted to set up edubuntu on it for them and don't want to have to use a wired ethernet connection (which of course works just fine). I'm happy to go get a new PCMCIA card for it as long as I know its going to bloody work. I've checked some compatibility lists which aren't terribly up to date so I'm none the wiser as to what I could pick up off the shelf these days and expect to work.

    I have to say I'd have thought the platform to have matured sufficiently by this point to not have encountered this issue.

    Any advice?
  2. Nothing intelligent or useful to say. Thought I'd share this: PCMCIA = People Can't Memorise Computer Industry Acronyms
  3. Welcome to the suck...

    If ndiswrapper doesn't do you any good, you might want read up on any another distribution which has had success with this driver (openSuSe?)
  4. I have a friend who did this successfully, so I asked him for his advice and he basically said "it's too much work".

    Not very helpful, sorry.
  5. Yeah ndiswrapper seems to be the only way to get it to work, which is what I'm using. When I tried Marvell windows drivers and the card lit up for the first time and found my SSID I got all excited. And then...just won't bloody authenticate on WPA.
  6. I spent days on the same problem and never got any further than you, wireless card lights were on, I could see networks but could not connect. I gave up and harboured a passionate hatred of Linux for quite some time. I haven't had the energy to try again, it was one of the most frustrating episodes of my life. Good luck.
  7. I could probably make it work. Got a way to get the laptop on a network and give me SSH access?

    If not I'd recommend getting a USB wifi dongle.

    Can do it anytime... I'm a Linux/Network dude for a living...
  8. Do you have access to a USB wireless dongle??

    I have one you can borrow to see if it works.
    You can always bring your lapflop in here and try it out.
    There is a guest wireless signal that we can try to hook up to.

    I work in Epping, you're welcome to swing past next week and try it out. I'm not here tomorrow as I'll be at the Island but am here next week.

    Let me know
  9. My advice?

    Restrict your device use to those devices specifically supported by the distro that you are using (or intending to use).

    In this case... get another wireless card.
  10. Unfortunate for your wallet, I agree with ZRX here, it'll be easier to simply use a wifi solution that genuine linux drivers are available for.
    It's been such a long time since I've had to mess around with ndiswrapper (I use intel based wifi exclusively) that I'd forgotten the problem still existed.
  11. Cheers - at the moment I'm doing the config via the live CD rather than blowing away the XP OS completely. I don't want to do it permanently until I'm sure I'll have working wireless - so letting someone else hack it to try and get it working will be somewhat pointless - although I appreciate the offer.

    Yeah I'd been through that list, but its not much use for the current card (which isn't listed) and I've looked via ebay to try and find a card thats on the list and reported as working to no avail - and not knowing the chipset doesn't help as that never seems to be listed in the product descriptions.

    Cheers Vic, might take you up on that. If there are USB wireless dongles that work I'd happily go buy one.

    Might do some research today and if I can see something that looks promising I might just bite the bullet and buy one to try.

    I'll be at the Island tomorrow myself :)

    Hence my question as to which card works ;)

    Looks like USB dongles fare better perhaps...will look into that.
  12. If you are able to get anywhere near pit lane let me know and I'll take it with me tonight
  13. Cheers Vic.

    Googled up some USB dongles, popped down to Centrecom and picked up a TP-Link TL-WN321G for $20.

    Well, I'm posting from the laptop via wireless\\:D/

    Bloody thing worked straight out of the box booting into the live CD!

    Tossing the Netgear card in a drawer.

    Thanks for the offer Vic...all sorted now I guess!
  14. Woot - gotta love a happy ending!
  15. +1

    good to see you got it sorted.
  16. I've got the same netgear card laying around somewhere. I got it working with Linux back in 2005 - royal pita tho - haxing the shit out of things and still not achieving full functionality (no encryption etc).

    Hardware support under linux is much better than then, but you have to understand that PCMCIA is legacy tech.