Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Cagiva Mito - starting problems

Discussion in 'Technical and Troubleshooting Torque' started by blackjacket, Jul 27, 2007.

  1. Hi all,

    I bought a mito last week, and it's been running well apart from a weakish battery. I charged that up and it cranks over nicely.

    Now last last night, I filled up half a tank of V-power at Shell (IIRC, couldn't find optimax), and it rode home fine.

    When I went to start it up yesterday morning, it started up first crank with choke and ran for about a minute. I left it running but it cut out while I was putting on my gear. After that, it absolutely refuses to fire up.

    I've almost drained the battery cranking, so I took to roll starting. Unlike before, it doesn't instantly fire up... it sounds like its firing, but very muffled, and when the bike stops, the rear tyre locks up and drags along. I tried this with and without choke, and with the fuel tap open and closed (thought maybe overfuelling).

    This morning, tried again, thinking I may have flooded it yesterday. Same story. What could be going on?? I don't see why just a change of fuel would do this (old owner says he used BP ultimate).

    Something else I observed (may have been like that all along) was that the bike rolls easily in neutral, but there is a bit of resistance when I shift into 1.

  2. Yeah fuel can make a bike difficult to start. I personally find that caltex and BP make it harder to start.
    The fuel prob then fouled your plugs making it even more hard to start.
    Change the plugs and fuel
  3. Get your battery fully charged, and while you're waiting, check your plug.
    If it's all black and oily, it can be cleaned by swishing it around in petrol, but preferrably replace it.

    I would definitely recommend sticking to the fuel that the previous owner used.
  4. IIRC Vpower is renamed optimax

    replace plug and avoid using Vpower