Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Bikes in gear but gear lever is not engaged.

Discussion in 'Bling and Appearance' started by Shayne, Jan 18, 2007.

  1. Hi, I have a 2001 R6 that I have started to experience a problem with. When I go up or down through the gears the lever does not engage after the gear change. If I put pressure on the lever from above it slips into position allowing me to go up/down another gear. This happens from first upwards at any speed between 0-100.

    Im not machenically minded so this may very well be a simple fix. Thanks
  2. Sorry mate, but I don't understand what is happening here.

    YOu can change gear, but the lever is not returning to the centre position?

    If so the spring inside the gearbox is broken.

    sorry to say, but I have heard stories about r1 gearboxs. Particully early ones.
  3. Yeah, when I change up from 1st to 2nd, the gear lever is just flapping after the change. I then have to apply presssure gently in a downwards motion before the lever returns to its central position (which seems to reingage the lever) i can then change to 3rd...... If it is a spring how much am I looking at to have it replaced???

    And yeah the R6's gear box has been pretty clunky from day one
  4. ok misread. Haven't heard anything bad about the r6.

    The spring is a real guess, based on a problem I once had with a bike. Could be a selector drum.

    Either way, it could well be engine out unless the r6 has a casette type box (engone know?) and thats getting dear.