Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

battery not holding charge

Discussion in 'Technical and Troubleshooting Torque' at netrider.net.au started by Snowman, Dec 1, 2008.

  1. Ive got a 93 Kawa ZZR250 that the battery keeps dying on, after a full charge it only lasts a few hours of riding around and then wont start again, the engine just turns over a few times then starts clicking.

    Also once while riding the lights all died then i tried to indicate and it started backfiring so i pulled over and it wont start.

    I have replaced the battery with a brand new one with the same results, just seems to last a bit longer, so could this be a wire out of place? the alternator thingy broken? id like to try and resolve this myself.



    thanks for advice.
     
     Top
  2. Have you checked that the charging system is fine?
    ie use a multimeter, or a quick check would be to see if your headlamps get brighter when you bring the revs up from idle to say 2000rpm+
     
     Top
  3. Alternator or regulator. I'm better alternator.

    As suggested above a volt meter across the battery terminals with 2000rpm dialed in will confirm. Should be reading close to 14.3V
     
     Top
  4. i did the lights test they didnt change at all at 2000 rpm or higher, how much am i looking at for a new alternator? is it something i can install myself? thanks for the tips
     
     Top
  5. As a guide , if you need to change the stator in the alternator , I check prices from a U.S. site and then add 50 percent , gives me an approx. price if I have to buy genuine from Kawa aus.

    U.S price is $254

    Get a meter and check as per previous posts, then trouble shoot from there.
     
     Top
  6. Don't just go and buy bits- get it checked by a mechanic or an auto elec before you go wasting money. It could be one of a number of things (my guess is regulator but who knows).
    As long as they can find the problem quickly, the parts will be the main cost, not installation.
     
     Top
  7. It is clicking because there isn't enough power in the battery to engage the starter motor... Running the engine doesn't use much power, but running the lights does... in an emergency (during the day :shock: ) you can unplug the headlight and keep going a while longer...

    Was this the start of the problem? or after it had started???

    Put a multi-meter across the battery, as the revs go up it should go up from 11.5V or so to 13V or so... if it doesn't do that, you aren't generating any electricity... nothing to do with the battery...

    With the ignition OFF, disconnect the +ve battery, set your multimeter to DC Amps and put the meter leads between the battery terminal, and the +ve lead... if it shows a reading, something is drawing power with the ignition off which will run the battery flat... still nothing to do with the battery...

    Unfortunately, most auto-electricians won't work on motorbikes, which puts you in the hands of motorbike mechanics. As with most things mechanical, it seems the fixing isn't that hard... it is the finding out what to fix that requires the skill...

    It's less than the least we could do :)...
     
     Top
  8. this was at night, scary O_O

    only had the bike for a week and has been doing it since i got it.

    a friends dad is an electrician ill see what he can do to help me find the problem, and i also know an auto-electrician that works on bikes from time to time, only for friends of friends tho :D

    thanks again for all help guys ive learned a bit about batteries from this haha
     
     Top
  9. It turns out the ground wire wasn't connected to the battery, the dealer i took it to for a service didn't re-connect it :? they also forgot to re-connect my front blinkers. Dunno if i'll take it there again.
     
     Top
  10. why would they touch your blinkers :?
     
     Top
  11. I believe they had to pull the fairing off to get at the carbies.
     
     Top
  12. Glad you didn't race out and buy a new battery???

    I think you owe Netrider a few beers, :wink:

    Cheers,
    Daewoo
     
     Top
  13. I DID!!

    lol, I just noticed a black wire with a ring on the end going no where and thought "hmm that looks like a ground wire!" and it was and now it works. im lucky i didnt go and buy a new regulator for it :roll:
     
     Top