Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

Aprilia RS125 2001. Engine keeps dying.

Discussion in 'Technical and Troubleshooting Torque' started by ychinchin, Jun 21, 2011.

  1. Hi guys

    I got a question about my RS125 and hoping you guys might have some suggestions.
    When I first got it, tried to go for a ride that night but I took off without warming up. After going down the road, I stopped on the side to make a phonecall, then when I started up again it died after about 5 seconds and we couldn't get it running again.

    Next day, I changed the spark plug and it started up. I let it warm up for about 10 minutes and took off to ride around for about 40 minutes.

    Tonight, I warmed up the bike for about 10 minutes then killed the engine while I waited for a friend which was another 5-10 minutes. Jumped on the bike and then it wouldn't start.
    Changed the spark plug again and now it starts up ... we went to a carpark and it just died while we were talking about what drills we should go over. Before it died though, it revved up to about 3500 and then the revs just went back down and died. Didn't respond to the throttle at all while revs were on its way down.

    Took the spark plug out and had a look, chucked it back in and starts up, about 1km later it died again.
    When we popped the tank up to have a look again, we kinda found that the fuel might not be feeding properly and adjusting it would get it started again for abit before dying.

    Sorry for the long post, just wanted to get some details in to give a better idea. Does this sound like the fuel isnt feeding or could it be something more than that ?

    The previous owner told me to use BR8 or BR9 sparks and I am currently using BR8. I have seen posts around saying to use BR9 or BR10, but I figured that it might have been tuned to use BR8 so I am just going with that.

    From what I have been told, there is a Keihin slide carby that was pulled out from a Honda CR250. Also has a powervalve and some kind of a custom pipe.

    Any suggestions/tips/hints greatly appreciated. Thanks guys

    Forgot to add, it has a Vapor dash that reads 10000kms. Owner told me it was about 6500 before the dash was isntalled.
    Also meant to have done a bottom and top end rebuild about 1500kms ago.
  2. Everyone I know including me is using BR10EG, check your choke and also that your fuel lines isnt being squished or overly bending when you close the tank.

    It does sound like fuel issue. With my one everytime I opened up the tank a bit of fuel goes through the line hence it started up for a bit before dying. I simply cut a small section of the hose and this solved the issue....................make sure that its fuel first before cutting anything.

    If it dies out again and wont start up, try putting a BIT of petrol through the spark plug hole and see if it starts up again.