Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

89 ZX2R not idling correctly

Discussion in 'Technical and Troubleshooting Torque' at netrider.net.au started by BeverlyHillsKawasakiNinja, Mar 10, 2014.

  1. Hey all,

    I have just repaired my gas tank over the weekend due to internal rust. On Friday night it was taken off, then on Saturday I had placed it back on and started it (which was working fine) however the fuel was still leaking so I had to make another patch repair.



    Last night, I placed the tank back on and started it. This time, it didn't idle at all. I really had to open up the throttle to even get it to start up. It then idled near 0 revs rather than the usual 2k revs.

    I have checked the petcock, the tank, and the fuel lines as these were the only parts I touched in the last few days however I am stumped in knowing what to look for.

    Is there anyway I can diagnose the issue by isolating each part? My hunch is that there is an issue with the petcock not letting enough fuel through.
     
     Top
  2. Should be an idle speed adjuster on one of the sides of the carburettor. it'll just be a little knob that you turn either clockwise or counterclockwise to adjust the idle speed. on my GPX its on the left hand side, just near the fuel tap, could be at a similar location on yours. maybe you bumped this whilst removing and installing the tank? if its not that, majke sure the vaccum line is fitted correctly between the tank and the carbs, make sure theres no holes in it or it wont let fuel through the tap.
     
     Top
  3. Thanks Jimmy I will have a look for the idle speed adjuster very soon.

    Would it be worth completely replacing the vacuum line? It is only a few cm's worth of line correct?
     
     Top
  4. Is there a filter on the fuel lines? Could have stirred up crap that now lives in the carbie.
     
     Top
  5. Probably not, however after the initial cleaning and first install of the gas tank, the motor was running fine. The work down in between the first and second install was only applying epoxy to the exterior which was allowed to cure and set.

    I don't see how any massive amount of crap could have found its way in fuel lines but I won't rule it out without inspecting the carbs. What would be the recommendation to fix them, after ruling out the other problems?
     
     Top
  6. YOU FOOL ! zxr's were only made for people with lots of time on their hands

    talking utter shit aside the idle speed controller is on the right side (when your sitting on the bike)- and after being worked on once mine had been knocked loose and was acting like a netrider moderator (see - not right in the head) reconnecting it back up solved the problem obviously.

    failing that just to clarify ....as these guys are very touchy at the best of times - you did wait for the bike to warm up abit even if that mean running with the choke on?
     
     Top