Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

2007 zx6r riders

Discussion in 'Technical and Troubleshooting Torque' started by discocbr, May 3, 2008.

  1. Was wanting to hear from other 07 zx6r riders who have a problem with a ticking or knocking noise coming from the engine after the break in period,I thought it was just limited to mine but after a little research i found that kawasaki may have used faulty valve buckets in this model and they tend to mushroom out making a tick or knock depending how badly worn they are.I have spoken to a kawi dealer and they are aware of the issue but kawasaki are not going to issue a recall.
    There are other threads on other forums predominently kawasaki ones that have reports of the valves failing into the bore.
    This worries me as a rider and kawasaki customer that they havnt recalled the bikes for this issue,They have since stoped making the part in question and another stronger bucket is available and apparently fitted to the 08 model.
    So at the moment i would like to hear from any other 07 zx6r owners to see how widespread this issue is.Cheers....

  2. Why not take it to the dealer? It might be covered under warranty.
  3. ^ +1.

    Take it and ask your dealer, or better yet, just call Kawasaki themselves and ask for information about it to confirm that it is a defect and will affect the bike negatively.
  4. Zx

    Take it back to your dealer..