Welcome to Netrider ... Connecting Riders!

Interested in talking motorbikes with a terrific community of riders?
Signup (it's quick and free) to join the discussions and access the full suite of tools and information that Netrider has to offer.

1996 zx6r cutting out at idle and other odd things

Discussion in 'Technical and Troubleshooting Torque' started by thecptn v1.1, Mar 23, 2011.

  1. I recently just got my zx6r with 37k on the clock, previous owner has claimed that its last service was sept last year, so it is well due for a service, I have been riding it about for the last two days, and it has cut out unexpectedly whilst idle with no warning, the only way to restart it is to put the choke out and ride and it goes away, it also seems to have a flat spot at 2800-3200 rpm at 1/8 throttle, im thinking dirty pilot jets, Ive put in new fuel and all, I will be sending it off for a major service soon and wont be riding it, it also seems to get hot after a few minutes in traffic, the thermo fans don't seem to be kicking in even when the needle is a sparrows fart away from the red which is starting to concern me, thermo problem?.

  2. Yep, new switch! But what I would recommend is to do a manual overide.
    And yes, sounds like carbs will have blocked ports, check it has a filter on the fuel line (dont rely just on the tank filter)
    Plugs may need changing also, check if their fouled.
  3. Sounds like it could be, but it is hard to tell, the owner placed a free flowing pipe and I dont think he bothered changing jets, so it could be either to lean on idle or just dirty jets or a combo of both, it does sound a bit rough for i4 at idle.